Version in base suite: 1.5.1-1

Version in overlay suite: 1.5.1-1+build1~deb10u1

Base version: nyancat_1.5.1-1

Target version: nyancat_1.5.1-1+build1~deb10u1

Base files: nyancat-server_1.5.1-1_all.deb

Target files: nyancat-server_1.5.1-1+build1~deb10u1_all.deb

New files in second set of .debs, found in package nyancat-server

-rw-r--r-- root/root /lib/systemd/system/nyancat-server@.service

Control files: lines which differ

Depends: nyancat (>= 1.5.1-1), init-system-helpers (>= 1.18~) 1.5.1-1+build1~deb10u1)

Postinst files: lines which differ

# Automatically added by dh_systemd_enable dh_systemd_enable/12.1.1
if [ "$1" = "configure" ] || [ "$1" = "abort-upgrade" ] || [ "$1" = "abort-deconfigure" ] || [ "$1" = "abort-remove" ] ; then
deb-systemd-helper unmask nyancat-server.socket 'nyancat-server.socket' >/dev/null || true
if deb-systemd-helper --quiet was-enabled nyancat-server.socket; 'nyancat-server.socket'; then
deb-systemd-helper enable nyancat-server.socket 'nyancat-server.socket' >/dev/null || true
deb-systemd-helper update-state nyancat-server.socket 'nyancat-server.socket' >/dev/null || true
fi
# Automatically added by dh_systemd_start dh_systemd_start/12.1.1
if [ "$1" = "configure" ] || [ "$1" = "abort-upgrade" ] || [ "$1" = "abort-deconfigure" ] || [ "$1" = "abort-remove" ] ; then
deb-systemd-invoke start nyancat-server.socket 'nyancat-server.socket' >/dev/null || true
fi

Postrm files: lines which differ

# Automatically added by dh_systemd_start dh_systemd_start/12.1.1
# Automatically added by dh_systemd_enable dh_systemd_enable/12.1.1
deb-systemd-helper mask nyancat-server.socket 'nyancat-server.socket' >/dev/null || true
deb-systemd-helper purge nyancat-server.socket 'nyancat-server.socket' >/dev/null || true
deb-systemd-helper unmask nyancat-server.socket 'nyancat-server.socket' >/dev/null || true

Prerm files: lines which differ

# Automatically added by dh_systemd_start dh_systemd_start/12.1.1
deb-systemd-invoke stop nyancat-server.socket 'nyancat-server.socket' >/dev/null || true